Logo SR Alpha 2017

NEW maxscript error

More
13 years 2 months ago - 13 years 2 months ago #1397 by avicohen2k
Hi when rendering high-ress (above A3)
I get a max script rollout handler exception - unknown system exception
it happens on the render start at prepering global lights manger,

this is an SR problem since if I close SR and hit render render goes fine
if I lower the res, render goes fine.
here is the max listner log:

-- Error occurred in bb71(); filename: C:\Program Files\Autodesk\3ds Max 2009\UI\MacroScripts\SolidRocksB08x.mse; position: 235380
-- Defined in encrypted script
-- called in bb1.pressed(); filename: C:\Program Files\Autodesk\3ds Max 2009\UI\MacroScripts\SolidRocksB08x.mse; position: 236190
-- Defined in encrypted script
>> MAXScript Rollout Handler Exception: -- Unknown system exception <<

tired both version, 0.75 and 0.85

please help me I'm short with time on this.

Avi.

EDIT:

I had another error when saving the jpg on lowerer ress. for some reason I got "unable to save bitmap" error.
I did some reading on CGarchitect and learned that it had something to do with the framebuffer and memory.
so I tried to render with no frame buffer(setting a save path in advance, even with SR I get no errors this time B) . so I guess the above error has something to do with the vray framebuffer.
though rendering without seeing the resualt is realy not healthy on my heart :blink:
(plus I want to save both rgb and alph seprate and that can be done only with the frame buffer on)

in case the problem is with frame buffer what is the best way to avoid this error?

I also noticed some talk about the bucket size (which means nothing to me) I tried changing it but that did nothing. what does that do? and maybe some help can still come from there?

Please,
the detail level of my work rests in your hands :)
Last edit: 13 years 2 months ago by avicohen2k.

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #1401 by subburb
Replied by subburb on topic Re:NEW maxscript error
hi Again, Avi,

for sure it looks like a ram issue..

using the max frame buffer will help to save some ram, for sure.

you can also try to activate the bitmap pager in max (see max preferences-->render tab) - this feature seems to have disappeard on max10

you can also use some tools like bigrender to help..

if you're in 32 bits os, you can try the famous /3GB swith tip in your boot.ini

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #1403 by avicohen2k
Replied by avicohen2k on topic Re:NEW maxscript error
Im on a 32 bit system (with 2g ram) don't know anything about a famouse swith. relavent?

found the bitmap pager (on max2009).
can I have some assistance with it? what is a good file size? what to fill in there? :)

are there any isuess with using the max frame buffer? reguarding the autoexpusre and other?
for now I noticed that when I click save the max buffer shows me the image without the expusre settings but the file saves correctly like it looked in the minipreview. is there a chance any settings will be lost?

thanks.

Avi :)

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #1407 by subburb
Replied by subburb on topic Re:NEW maxscript error
bitmap pager : leave defaults values for starting... i've forgotten the settings because now i'm on 12GB station (only 120 € to have 12GB corsair DDR3 !!)

no issues with the max frame buffer, SR works well with both Max and Vray framebuffers.
just one thing : if you're using gamma correction + max frame buffer, please avoid to zoom in and/ or make a copy because of double gamma application in this case.
the best thing is to use the autosave function (or manual saving) to be safe.

you can control your saved image in photoshop, but normally gamma is ok, same than with solidrocks.

the 3GB switch (XP) allow XP to allow a running process to use more than 2GB of ram and push up to 3GB.
even with 2GB of ram, this feature saves my life few years ago when making huge animation with 2GB ram.

be careful when you setup it, as you're modifing the boot.ini of your computer !!!
i'm not responsible of bad manipulations ;)

here are some more infos about /3GB:
msdn.microsoft.com/en-us/library/ms791558.aspx

and how to setup it :
technet.microsoft.com/en-us/library/bb124810%28EXCHG.65%29.aspx

note : i suggest to not modify the line in boot.ini, but make a second line with a copy of the first one, modified with /3Gb. Like this, you'll have choice between regular os and /3GB os when you start you PC, more safe ! ;)

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #1414 by avicohen2k
Replied by avicohen2k on topic Re:NEW maxscript error
Hi J,

that sounds interesting (3g on my 2g system???)

the article you sent me says it doesn't support my system (XP studnet(like standart) SP 2 or 3 dont remember :P )
this looks like for windows servers..
Before you perform the procedure in this topic, be aware of the following:

The /3GB switch is supported only on the following operating systems:

Windows 2000 Advanced Server

Windows 2000 Datacenter Server

Windows Server 2003 Standard Edition

Windows Server 2003 Enterprise Edition

Windows Server 2003 Datacenter Edition

is it safe? and if so, which ex to use? the 2000server or the 2003server?

Please Log in or Create an account to join the conversation.

More
13 years 2 months ago #1415 by subburb
Replied by subburb on topic Re:NEW maxscript error
i've made this on many XP32 OS, always worked fine.

but make a complete backup/ghost before doing this ! ;)

Please Log in or Create an account to join the conversation.

Time to create page: 0.248 seconds

Contact informations

Subburb

32, Rue theophile Gautier
33110 Le Bouscat
FRANCE

(+33) 6 73 03 72 29

Newsletter

Keep in touch with us

facebook_32 youtube_32 vimeo_32